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Welcome

Avenza welcomes you to mapmaking in the 21st century!

Combined with Adobe Illustrator, MAPublisher has revolutionized the art of mapmaking by allowing spatial data 
to be used to create maps inside a vector graphics program. MAPublisher allows all your cartographic tasks to be 
performed where they should be done; in a powerful graphics environment.

MAPublisher 8 improves on the already powerful tools of previous versions by adding additional file support, 
additional tools and improvements to existing tools.

This Quick Start Guide assumes that the user is familiar with Adobe Illustrator CS4 or CS5 and has at least a basic 
understanding of geographic information systems (GIS) terminology and concepts. The exercises in this guide are 
meant to help you quickly start working with the basics of MAPublisher. Not all MAPublisher tools are explained 
in this document. To gain a better understanding of all the features and tools MAPublisher has to offer, use this in 
conjunction with the MAPublisher 8.4 User Guide and MAPublisher 8.4 Tutorial Guide.

By following these tutorials you will learn how to create maps using MAPublisher tools in Adobe Illustrator. 
This guide covers the steps necessary to build a map and perform fundamental cartographic and GIS tasks. It is 
recommended to start from the beginning and work your way through the exercises. However, it is also possible to 
start at any of the exercises.

Quick Start Guide Data

All the exercises in this guide will use GIS data supplied in the MAPublisher installer. After installation, you can find 
the Quick Start Guide data in the following location on your hard drive:

Windows XP
C:\Documents and Settings\All Users\Shared Documents\Avenza\MAPublisher 8\Quick Start Guide & Data\Quick Start Data

Windows Vista and Windows 7
C:\Users\Public\Documents\Avenza\MAPublisher 8\Quick Start Guide & Data\Quick Start Data

Note:	 This data may be accessed through the Windows Start menu Avenza program group.

Mac OS X
/Applications/Avenza/MAPublisher 8/MAPublisher Tutorials/Quick Start Guide & Data/Quick Start Data

You are encouraged to experiment with your own data to gain additional experience with MAPublisher tools, 
functions and features.
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1  Getting Started

1.1	 Purpose

The purpose of this exercise is to create a simple map of downtown Vancouver, B.C., Canada and to export it as a 
Flash map for Web presentation. A 600 px by 600 px sized Adobe Illustrator document will be used and optimized to 
be displayed in a Web browser.

The Flash map will be used to represent restaurants, hotels, and points of interests in downtown Vancouver, and will 
display information such as their address, phone number, and Web site. In addition, some pictures and logos will be 
inserted into callouts to catch the interest of readers.

The necessary GIS data (vector and raster), additional information, and Web images are included with every 
installation of MAPubilsher. This Quick Start Guide will guide you through a typical MAPublisher work flow of map 
creation—from data import to final export to Flash. It can be used as a base to build up your own work flows for 
cartographic production.

1.2	 Know your data

The Quick Start Data folder contains vector, raster, and additional GIS files for import into MAPublisher.

Name (main file) Format Type Description Coordinate System

\Quick Start Data\Vector Files\Geodetic Data

Land.shp Esri Shapefile Area Land boundaries Geodetic WGS84

Parks.shp Esri Shapefile Area Park areas Geodetic WGS84

River.shp Esri Shapefile Line Rivers Geodetic WGS84

Water.shp Esri Shapefile Area Water bodies on land Geodetic WGS84

\Quick Start Data\Vector Files\Projected Data

Hotels.shp Esri Shapefile Point Hotels Projected NAD 83 / UTM 10N

Restaurants.shp Esri Shapefile Point Restaurants Projected NAD 83 / UTM 10N

Neighbourhoods.mif MapInfo MIF/MID Point Neighbourhoods Projected NAD 83 / UTM 10N

Boundary.mif MapInfo MIF/MID Area Map extent Projected NAD 83 / UTM 10N

Roads.tab MapInfo TAB Line Road network Projected NAD 83 / UTM 10N

\Quick Start Data\Raster Files

VancouverDowntown.tif GeoTIFF Raster Satellite image Projected NAD 83 / UTM 10N

\Quick Start Data\Additional Files

PointsOfInterest.csv Text (csv) Attribute Points of interest Geodetic WGS84

RoadCategory.dbf DBF (Excel) Attribute Road categories N/A

The roads, rivers, land, and water information were extracted from the Avenza MAPdataCanada data library 
and the parks, hotels, restaurants, neighbourhood, and points of interest were manually digitized. The 
VancouverDowntown.tif image was acquired and georeferenced by Avenza Systems using Geographic Imager for 
Adobe Photoshop.
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The two subfolders containing images used during the Web tagging process are:

•	 The PointsOfInterest subfolder contains images referred to in attribute fields image and logo_image of 
the PointsOfInterest.csv table

•	 The Restaurants subfolder contains images referred to in attribute fields PICTURE1 and PICTURE2 of 
Restaurants.shp file

Quick Start Template

The Quick Start Template is an Adobe Illustrator file that contains information and data needed by the user to complete 
this guide. Included in the template file are three sets of styles that will be used during the styling of the map:

•	 Graphic styles library (used for line and area features)
•	 Symbol library (used for symbolizing points)
•	 Character style library (used for labeling)

Also included in the Quick Start Template are predefined MAP Stylesheet, MAP Selection Filters and layers. If more 
information on a particular feature of MAPublisher is needed, please refer to the MAPublisher 8.4 User Guide or the 
MAPublisher 8 Tutorial Guide.

1.	 In Adobe Illustrator, open Quick Start Template.ait located in \MAPublisher 8\Quick Start Guide & Data (the .ait 
extension is an Adobe Illustrator template file). 

A blank artboard opens with a 600 px by 600 px dimension. The template includes predefined styles, symbols and 
layers needed to complete the Quick Start exercises. The size of the document here determines the final size of the 
Flash map viewed in a Web browser.

Note:	 Customize the Adobe Illustrator workspace to make it easier to access the panels. It may look different than 
the image above if MAPublisher is opened for the first time. Read Customizing the workspace in the Adobe 
Illustrator help guide for more information.
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2  Import GIS Vector Data

2.1	 Import data using Simple Import

1.	 In the MAPublisher toolbar, click the Simple Import button . Alternatively, in the Adobe Illustrator menu, 
choose File > Import MAP Data > Simple.

2.	 Choose Esri Shapefile from the Format drop-down list and click the Browse button.
3.	 Navigate to \Quick Start Data\Vector Files\Geodetic Data and select all four files (Land.shp, Parks.shp, River.shp and 

Water.shp) and click Open.

The four files are listed in the Dataset box in the Simple Import dialog box.

Note:	 The Source Coordinate System displays WGS84. This is stored in the shapefile projection format (.prj file). 
MAPublisher can import multiple files at once using Simple Import as long as the file format and coordinate 
system are the same.

4.	 Make sure the dialog box matches the one above and click OK.

Notice that in the Adobe Illustrator Layers panel, there are four new layers called River_line, Water_area, 
Land_area and Parks_area. In the MAP Views panel ( ), there is a new MAP View also containing the layers.

5.	 In the MAP Views panel, double-click the new MAP View to edit it. Change the name to First MAP View and click 
OK to accept the changes and close the MAP View editor dialog box.
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2.2	 Import data using Advanced Import

You'll be adding additional vector data of different formats using Advanced Import.

1.	 In the MAPublisher toolbar, click the Advanced Import button . Alternatively, in the Adobe Illustrator menu, 
choose File > Import MAP Data > Advanced. 

2.	 Click Add to open the Add dialog box and if necessary, choose Esri Shapefile from the Format drop-down list. Click 
Browse, navigate to \Quick Start Data\Vector Files\Projected Data, select the two files Hotels.shp and Restaurants.shp, 
click Open and then OK.

3.	 Again, in the Advanced Import dialog box, click Add and choose MapInfo MIF/MID from the Format drop-down list. 
Click Browse, select the two files Boundary.mif and Neighbourhoods.mif, click Open and then OK.

4.	 Finally, click Add, and choose MapInfo TAB from the Format drop-down list. Click Browse button to open the data 
source browser, select the file Roads.tab, click Open and then OK.

Use the horizontal scroll bar to view that all the data layers are present. MAPublisher automatically detects the 
NAD83 / UTM zone 10N coordinate system and displays it.

5.	 Under Destination MAP View, leave the New based on option as the default and click OK to accept the changes 
and to close the Advanced Import dialog box.

Note:	 The New based on option bases a new destination MAP View on the coordinate system information listed in 
the drop-down list. The Use existing option chooses an existing MAP View as a destination to where this data 
is placed.
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Notice that five new layers are added in the Adobe Illustrator Layers panel: Hotels_point, Boundary_area, 
Neighbourhoods_point, Restaurants_point, and Roads_line. In the MAP Views panel ( ), there is a new MAP 
View containing the imported layers. 

6.	 In the MAP Views panel, double-click the new MAP View to edit it. Change the name to Vancouver Downtown.
7.	 Click OK to close the MAP View editor dialog box.

The layers in the two MAP Views are not matching because they are based on two different coordinate systems 
and two different scales. Tutorial 3 will provide steps to reproject all the layers into the same coordinate system.

2.3	 Import point data

1.	 In the MAPublisher toolbar, click the Simple Import button .

2.	 Choose Delimited XY Text Data from the Format drop-down list. Click the Browse button, navigate to  
\Quick Start Data\Additional Files, select PointsOfInterest.csv and click Open.

3.	 The Settings dialog box appears. Under Coordinate Format, choose Decimal Degrees (D+[.d*]) in the Format 
drop-down list.

4.	 Under Coordinate Columns, choose Longitude: -123.127416 in the Longitude drop-down list. In the Latitude 
drop-down list, choose Latitude: 49.299093.

5.	 Make sure that the Use first line as a header option is checked (because the first line in the text file contains 
column headings). This option is checked if it is automatically detected.
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Leave Specify Schema settings as their default. These options allow you to customize the schema for each 
attribute column. More information is available in the MAPublisher 8.4 User Guide.

6.	 Click OK to accept the settings.
7.	 Text files do not hold information about the coordinate system so it must be specified. In the Source Coordinate 

System section, check the Same As option box and select First MAP View in the drop-down list.

8.	 Click OK to continue with the import.
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9.	 Since the coordinate system was chosen to be the same as First MAP View, select Add to: First MAP View under the 
Destination MAP View area.

10.	 Click OK to add the points of interest to the First MAP View.
11.	 In the Adobe Illustrator Layers panel, a new layer called PointsOfInterest_point is added. It is also contained in the 

First MAP View in the MAP Views panel.
12.	 Save the document as Vancouver Downtown.ai to the Quick Start Guide & Data directory. Leave all save options as 

the default.
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Continue working with your map or open Vancouver Downtown 3.ai.

3.1	 Reproject all layers to NAD83 / UTM Zone 10N

1.	 In the MAP Views panel, select all the layers contained in First MAP View (Land_area, Parks_area, 
PointsOfInterest_point, River_line and Water_area).

2.	 Click the Switch MAP View button at the bottom of the MAP Views panel and click Switch to “Vancouver Downtown”.

All layers are moved into the other MAP View, Vancouver Downtown. In the process of switching, the data is 
transformed to the NAD83 / UTM zone 10N coordinate system. All the data is now in the same coordinate system 
and aligns correctly.

3.	 In the MAP Views panel, select First MAP View and click the Delete button on the lower right corner to remove it 
(this MAP View is not needed for the remainder of the exercise).

3  Reproject and scale
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3.2	 Scale and edit MAP View

1.	 In the MAP Views panel, double-click the Vancouver Downtown MAP View to edit it.
2.	 In the MAP View editor dialog box, choose Thumbnails & Boxes in the Preview drop-down list to see a preview of 

the map document.
3.	 In the Scale box, type 22100 to achieve a scale of 1:22,100.
4.	 Select the Top Center position (click the top center square) in the Page Alignment frame.

5.	 Click OK to accept the settings and close the MAP View editor dialog box.

The layers are scaled and centered to fit the top of the page. The chosen scale is appropriate to fit the data in the 
document size. It needs a few more datasets that you'll in the next section.

6.	 If necessary, save your Adobe Illustrator file.
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4  Join Table to MAP Attributes

Continue working with your map or open Vancouver Downtown 4.ai.

1.	 In the Adobe Illustrator Layers panel, select all art on the Roads_line layer. To do this, click the target button 
(circle to the right of the layer name) to select all art on this layer.

2.	 In the MAPublisher toolbar, click the MAP Attributes button . Alternatively, choose Window > MAPublisher > 
MAP Attributes. In the panel, click the FULL_NAME column title to sort it.

There is only one attribute column called FULL_NAME. The  icon beside the column name designates it as a 
String attribute type. Scroll down the table to see the other entries.

3.	 Click the Join Table button. 
4.	 In the Join Table dialog box, click Browse and navigate to \Quick Start Data\Additional Files, select 

RoadCategory.dbf, and click OK. Then choose the following settings (keeping all other options as default):
•	 Source Matching Column: ROADNAME
•	 Destination Matching Column: FULL_NAME

        

Note:	 In order to successfully join a table, both the MAP Layer and the data table must share at least one common 
attribute column with matching values.

5.	 Make sure the dialog box matches above and click OK. Notice that a new attributes called CATEGORY is added 
to the Roads_line table. If necessary, sort the columns to see the same results above.

6.	 If necessary, save your Adobe Illustrator file.
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5  Styling and MAP Themes

Continue working with your map or open Vancouver Downtown 5.ai.

5.1	 Organize layers

1.	 Rearrange the layer order in the Adobe Illustrator Layers panel as follows (click and drag the layers in the panel):

5.2	 Apply graphic styles to areas manually

1.	 In the Adobe Illustrator main menu, choose Window > Graphic Styles to open the Graphic Styles panel.

2.	 In the Adobe Illustrator Layers panel, select all art on the Boundary_area layer by clicking the target button.
3.	 Click the Boundary graphic style to apply it to all selected art on Boundary_area (hover over the graphic style 

thumbnail to see the name of it).
4.	 Select all art on the Water_area layer and apply the Lake graphic style.
5.	 Select all art on the Parks_area layer and apply the Parks graphic style.
6.	 Select all art on the Land_area layer and apply the Land graphic style.

Also notice the three additional graphic styles for the roads called Roads-Cat1, Roads-Cat2 and Roads-Cat3.
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5.3	 Apply Stylesheet MAP Theme to line layer

1.	 In the MAPublisher toolbar, click the MAP Themes button . 

The Quick Start template file contains two existing Stylesheet MAP Themes: Roads and Symbols. These themes 
were created for your convenience, but they do not contain any rules yet to style the map. You'll create some 
rules to style the Roads and Symbols layers. For more information on creating and using MAP Themes, refer to 
the MAPublisher Tutorial Guide or the MAPublisher User Guide.

2.	 In the MAP Themes panel, double-click the Roads Stylesheet MAP Theme.

3.	 Click the Layers button to add the Roads Layer so rules can be generated for it. In the Select Layers dialog box, 
click the check box for the Roads layer and click OK.



17MAPublisher 8 Quick Start Guide
5  Styling and MAP Themes

Notice that the Layer status lists the Roads layer. You'll now have to add generate rules for it.

4.	 Click the Batch Generate Rules button.
5.	 In the Rule Generator dialog box, choose CATEGORY from the Attribute drop-down list and click the Load 

button. Under Data Classification, choose Unique Values from the Method drop-down list.

Notice that there are three categories for roads. The three graphic styles for roads, as seen in the previous 
exercise, can be assigned to these rules.

6.	 Under Visual Property Assignment, click the check box beside Set style, then click the Select button.
7.	 In the Select Styles dialog box, select Roads-Cat1 and click the right-arrow button to move it into the Selected 

column. Repeat for Roads-Cat2 and Roads-Cat3. Then click OK.
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8.	 The styles have been successfully assigned to each rule. Click Add to close the Rule Generator.

9.	 The new rules are now listed. Click Apply to apply the rules to the map.
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The road lines styled properly according to the rules defined in the MAP Themes.

5.4	 Apply Stylesheet MAP Theme to point layers

1.	 In the MAP Themes panel, double-click the Symbols Stylesheet MAP Theme.

In the Edit Stylesheet Theme, the Hotels_point, Restaurants_point, and PointsOfInterest_point layers are chosen 
and the expression and symbol styles are all defined. 

2.	 Click each rule to see its expression and symbol properties.

Notice how the science and theatre categories have the wrong symbol assigned to them (both are assigned a 
hotel symbol).
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3.	 Correct the errors and choose the appropriate symbol for the science and theatre categories. Assign the science 
category the science centre symbol and the theatre category the museum and point of interest symbol.

The three point layers used above can be used in a single Stylesheet MAP Theme because they share an 
identical attribute structure. You'll also edit all the rules at the same time to change the visual scale.

4.	 Click the Edit Visual Property Ramps button. In the Edit Visual Property Ramps dialog box, click the check box 
beside Set scale and type 60% into both boxes. Hint: set the scale in the box on the right before the left. Click OK.

5.	 In the Edit Stylesheet Theme dialog box, notice that the scale for each rule is now set to 60%. Click OK to 
confirm the edits.
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6.	 In the MAP Themes panel, click Symbols to select it, then click the Apply  MAP Theme button.

The symbols are applied to the point layers according to the settings in the Symbols stylesheet MAP Theme.

7.	 If necessary, save your Adobe Illustrator file.
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6  Labelling

Continue working with your map or open Vancouver Downtown 6.ai.

1.	 In the MAP Views panel, under [Non-MAP layers], click and drag the Neighbourhood Labels layer to the 
Vancouver Downtown MAP View.

2.	 In the Undefined Layer dialog box that appears, specify the MAP layer Feature type to Text, and click OK.

3.	 In the Adobe Illustrator Layers panel, click the target button next to the Neighbourhoods_point layer title to 
select all the art on that layer.

4.	 Open the Adobe Illustrator Character Styles panel (choose Window > Type > Character Styles).
5.	 Click the Labels_Style style.
6.	 In the MAPublisher toolbar, click the Label Features button .
7.	 In the Column drop-down list, choose AreaName (the Destination is set to the first available Text layer).
8.	 Under Label Settings, set the Point Labels position to Bottom Middle and click OK.

9.	 In the Adobe Illustrator Layers panel, turn off the Neighbourhoods_point layer as it will not be needed for the 
rest of the exercise.
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The text from the AreaName attribute of the Neighbourhoods_point layer is inserted on the map, in the text layer 
Neighbourhood Labels.

10.	 If necessary, save your Adobe Illustrator file.
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7  Import GIS Raster Data

Continue working with your map or open Vancouver Downtown 7.ai.

1.	 In the MAP Views panel, under [Non-MAP layers], click and drag the Image layer to the Vancouver Downtown 
MAP View.

2.	 In the Undefined Layer dialog box that appears, specify the MAP layer Feature type to Image, and click OK.

3.	 In the Adobe Illustrator Layers panel, select the Image layer if it is not already selected. In the Adobe Illustrator 
main menu, choose File > Place and navigate to \Quick Start Data\Raster Files, select VancouverDowntown.tif and 
click Place.

The image gets placed on the artboard but at the incorrect spatial location and scale. Register the image so that 
it can have a proper spatial reference.

4.	 While the image is selected,  click the Register Image button  on the MAPublisher toolbar.
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5.	 In the Register Image dialog box, click Load File and navigate to \Quick Start Data\Raster_Files and open 
VancouverDowntown.tif (a GeoTIFF contains georeference information and the image data).

6.	 Click OK to register the image.

The image is resized and positioned at the proper spatial location.

7.	 If necessary, click and drag the Image layer below the Land_area layer in the Adobe Illustrator Layers panel.

8.	 If necessary, save your Adobe Illustrator file.
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8  Legend and Scale Bar

Continue working with your map or open Vancouver Downtown 8.ai.

8.1	 Create a legend

1.	 In the MAP Views panel, under [Non-MAP layers], click and drag the Legend layer to the Vancouver Downtown 
MAP View. In the Undefined Layer dialog box that appears, set the MAP layer Feature Type to Legend and click OK.

2.	 In the MAP Themes panel, select Symbols and click the Create Legend button at the bottom.

3.	 A message states there are no legend entries in the stylesheet and asks if you want to create a default legend, 
click Yes to continue.

The Create Stylesheet Legend dialog box appears. A preview shows what the legend may look like. You'll change 
several options to make a nicer looking legend.
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Since the "theatre", "museum" and "gallery" have the same symbol to represent it, you'll remove two of them 
and leave only one to represent them as a point of interest.

4.	 In the Legend Entries section, select CATEGORY: "museum" in the entries list and click the Remove button. Also, 
remove the CATEGORY: "theatre" entry.

5.	 Change the display name of each entry in the Display name box. Select the CATEGORY: "gallery" entry and 
rename it to Point of Interest. Rename the remaining entries like so:

6.	 In the Legend Key Options, change the size of the icon to 15.00 px by 15.00 px. Change the Space between 
entries to 5.00 px

7.	 In the Additional Options, click the Draw border option to uncheck it.

8.	 Click the Create button to finish and place the legend on the document.

By default, the legend is positioned at the centre of the map on the Legend layer.
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9.	 Move the legend to the centre of the page, below the map.

Note:	 These legend categories are grouped together.

8.2	 Create a scale bar

1.	 In the MAP Views panel, under [Non-MAP layers], click and drag the Scale Bar layer to the Vancouver Downtown 
MAP View. In the Undefined Layer dialog box that appears, set the MAP layer Feature Type to Legend and click OK.

2.	 With the Scale Bar layer selected, click the Scale Bar button on the MAPublisher toolbar . If necessary, choose 
Scale Bar as the correct MAP Legend layer to use. In the Scale Bar dialog box, expand the Advanced section and 
make sure your settings match the following and click OK.

Interval: 200

Display scale value, show 
above, align center

Change text to Arial Regular, 
12.00 pt

Display units to right of last 
interval label
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3.	 Select the scale bar and reduce the size of the bounding box around the object. The horizontal scale can also be 
changed this way and will modify the bar increments automatically according to the width.

4.	 Move the scale bar to the lower left corner of the map extent.

5.	 If necessary, save your Adobe Illustrator file.



30 MAPublisher 8 Quick Start Guide
9  Export to Web

9  Export to Web

Continue working with your map or open Vancouver Downtown 9.ai.

9.1	 Finalize map

1.	 In the Adobe Illustrator Layers panel, select the Legend layer.
2.	 Using the Type tool, type Vancouver Downtown and move it to the upper right corner of the map. Use a white color 

and larger font or choose the Title_Style from the Character Styles panel. Optionally, add a drop shadow to the 
text (choose Effect > Stylize > Drop Shadow) to make it stand out.

3.	 Select all art on the Land_area, Parks_area, and Image layers (Ctrl+click on PC and Cmd+click on Mac) using the 
target buttons. Open the Transparency panel (choose Window > Transparency) and change the opacity to 75% 
for all three layers.

       

4.	 Select all art on the Hotels_point, Restaurants_point and PointsOfInterest_point layers and open the MAP Attributes 
panel to review the attributes schema of each. Use the Layer drop-down list to switch between selected layers. 
Become familiar with the attribute structure before exporting to a Flash map.



31MAPublisher 8 Quick Start Guide
9  Export to Web

9.2	 Using MAP Web Author

The MAP Web Author panel provides access to create and edit web tagged content. First, you'll create callouts for 
the Hotel points layer, then for the Restaurants and Points of Interest layers.

1.	 In the MAPublisher toolbar, click the MAP Web Author button .
2.	 From the panel option menu, choose Specify Source Media Folder.

3.	 In the Specify Source Media Folder dialog box, select the Relative Path option, browse to the directory 
\MAPublisher 8\Quick Start Guide & Data, and click OK.

Note:	 An empty relative path indicates the same folder as the document. 

4.	 In the Adobe Illustrator Layers panel, select all the points on the Hotels_point layer.
5.	 In the MAP Web Author panel, click the Edit button.
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6.	 In the Multiple Web Tag Dialog dialog box, change the callout title to <b>%HOTEL_NAME%</b>.

Alternatively, copy the text from the Web Author Formatting.txt file (located in \Quick Start Guide & Data\Quick Start 
Data\Additional Files).

7.	 Click the Callout Preview button, then click the Auto Size check box to automatically resize the callout.
8.	 Type (or copy from Web Author Formatting.txt) the following text content for the callout: 

Address: %ADDRESS%<br>
Telephone: %TELEPHONE%<br>
<br>
Visit the <a href="http://%WEBSITE%">website</a>

This text is comprised of HTML and references to the attribute table for the specific layer. For example, text 
between % signs refer to attribute names and <br> indicates a line break. The results of this formatting can be 
seen in the Callout Preview window. For more information, refer to chapter 15 of the MAPublisher User Guide.

Attribute column information may also be added using the <insert attribute> drop-down list in the Web Tag 
Dialog dialog box. This essentially adds attributes (e.g. %ADDRESS%) as variable which ensure that any changes 
to the information will still populate the Web tags.

9.	 Make sure the dialog box matches the one above and click OK.
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Now create callouts for the restaurant points layer.

10.	 In the Adobe Illustrator Layers panel, select all the points on the Restaurants_point layer.
11.	 In the MAP Web Author panel, click the Edit button.
12.	 In the Multiple Web Tag Dialog dialog box, change the callout title to <b>%RESTAURANT%</b>.
13.	 Click the Auto Size check box.
14.	 In the Callout Image frame, select the By Attribute option and type %PICTURE1% in the box above it.
15.	 Type in (or copy from Web Author Formatting.txt) the following text content for the callout:

Speciality: <b>%SPECIALITY%</b><br>
<br>
Address: %ADDRESS%<br>
Telephone: %TELEPHONE%<br>
Webpage: <a href="http://%WEBSITE%">%WEBSITE%</a>

Note:	 Images can be added to callouts that are referenced in the attribute table (done in this exercise) or done 
manually from any location. The Callout Preview is enabled by default. Use the Previous and Next buttons at 
the bottom of the dialog box to rotate through the callouts.

16.	 Make sure the dialog box matches the one above and click OK.
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Now create callouts for the points of interest point layer.

17.	 In the Adobe Illustrator Layers panel, select all the points on the PointsOfInterest_point layer.
18.	 In the MAP Web Author panel, click the Edit button.
19.	 In the Multiple Web Tag Dialog dialog box, change the callout title to <b>%PlaceName%</b>.
20.	 Click the Auto Size check box.
21.	 In the Callout Image frame, select the By Attribute option and type %logo_image% in the box above.
22.	 Type in (or copy from Web Author Formatting.txt) the following text content for the callout:

Address: %Address%<br>
<br>
Telephone: %Telephone%<br>
<br>
Visit our <a href="http://%Web%">webpage</a>

23.	 Make sure the dialog box matches the one above and click OK.

24.	 If necessary, save your Adobe Illustrator file.
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9.3	 Export to Web

1.	 In the MAP Web Author panel, click the Export button.

2.	 Beside the Export Location box, click the Browse button, navigate to \MAPublisher 8\Quick Start Guide & Data and 
create a new folder called Vancouver, type index.html as the file name and click Save.

3.	 In the layers list, under the User Toggle column, check the boxes for Hotels_point, Restaurants_point and 
PointsOfInterest_point.

Optionally, click the Viewer Style and Viewer Settings tab to view all the settings and options that can be 
potentially changed. However, for this tutorial, leave them at the default settings.

4.	 Make sure the dialog box matches the one above and click Export.
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The Web Export Log dialog box shows the results of the export.

5.	 Click the Export Folder link at the top of the dialog box to open it in a file browser.

6.	 Open index.html in a Web browser (such as Internet Explorer, Mozilla Firefox or Safari).

Note:	 To be sure that Flash maps are viewed properly, update to the latest Flash Player version (download it from 
the Adobe website at www.adobe.com). If you encounter Adobe Flash Security settings, please follow the 
on-screen instructions to allow access to the export folder.
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Navigate the map using the mouse to pan and the zoom buttons and slider on the left hand side. Click the symbols 
to see the callouts that you created. In the layers list, toggle on and off the layers you specified during export. The 
overview map can be used to navigate the map when zoomed in to the main map.

All of the navigation tools and surrounding map elements, like the overview map and search box, can be 
customized in the Advanced tab of the Web Export Dialog. For in-depth information on MAP Web Author, see the 
MAPublisher 8 Tutorial Guide and Chapter 15 of the MAPublisher 8.4 User Guide. These documents are installed 
with MAPublisher 8 and can also be downloaded from http://www.avenza.com/documentation.

To quickly create a geospatial PDF of the Vancouver downtown map, return to Adobe Illustrator and click the Export 
Geospatial PDF button in the MAPublisher toolbar.  Choose a location to save the PDF and click OK. You can find 
more information about geospatial PDF in the MAPublisher 8 Tutorial Guide and in Chapter 17 of the MAPublisher 
8.4 User Guide.

Congratulations, you have completed the MAPublisher 8 Quick Start Guide. From here, you can look at more 
detailed and advanced exercises in the MAPublisher 8 Tutorial Guide, the MAPublisher 8.4 User Guide and the 
Avenza Resources blog and user forum for tips and tricks (www.avenza.com).
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